Robotpirate Forums

Projects => ArduiNIX => Topic started by: justfred on March 27, 2010, 11:25:10 PM

Title: Questions from a dim bulb
Post by: justfred on March 27, 2010, 11:25:10 PM

Just got my kit, and I was really impressed with how well it went together!  I've done other nixie clock kits, and I've got the ones from Ogi Lumen as well - I liked the way this one works as a shield.

I have several random questions and observations.

Here's my setup:


More pictures: (

I've got an old set of tubes I got from a surplus place that I've hooked this up to.  I'm pretty sure these are b5092.  (Actually I took it apart and they're marked Burroughs B15 6319, and they're socketed.) (

Have also ordered some IN-17s for other projects that I'll try once they come in - will probably order another ardunix and the IN-17 board at that point.

1) In the assembly instructions (flash), step 6 (C3) calls for a 500v 2200pF cap, or a 50v .01uF cap.   The master parts list shows a 500V 5.6 pF NPO Capacitor, which is what was in my kit.  I was a little confused by this - but capacitors often confuse me.

2) I understand from several schematics that I should put a resistor, around 10K, on the anode of each bulb.  I started by putting one on each anode of the board, but I think that's incorrect (they're used to buffer the power spikes or something so one on each tube works better).  Pictures are before.

3) It seems like my power output is pretty low.  My leftmost bulb doesn't always light.  I test 173v at the test pin when I'm not plugged in to the Nixies, which I guess is okay - the 5092 datasheet calls for 170v.  When I'm plugged in the test pin drops to about 150v - maybe this is expected?  I've turned the pot R19 all the way up (to the left) - makes a little bit of difference, but still doesn't light consistently.  When I plug in only this bulb, it works fine, and all the digits light - but when everything else is plugged in, it only flickers now and then.  I'm using a delay of 2, but longer delays don't seem to light that bulb.  The other issue might be that, if this device was once a clock or counter, that position might have rarely changed?  (Having swapped tubes, that bulb does seem a bit burned out, but the first one still flickers.)

4) The hardest part for me to find has been a short (6 inch or so) 4-pin ribbon cable.  Would be awesome if this were included in the kit.  Right angle headers would have saved me a trip to Fry's.

5)  Obviously, as a clock I'm going to want to tap in for setting buttons, and possibly for a real time clock, gps, I'm also thinking maybe a thermometer or other input.  I got some femaie headers with long pins, that will probably work to "pass through" all the arduino signals - this is an aspect of "shields" that I haven't really understood.  But I assume I can determine the pins being used by the ardunix and use any of the others.

6) I've also ordered a Wiseduino ( and I'm going to see if I can get this to cooperate with the ardunix.

7) Finally, I'd like to try one of these with a VFD display - I've got a bunch of those as well.  I understand that I use a different cap for C3, something "smaller".  I guess I just trial and error (testing voltage) to find the right size?  And I believe the VFDs want a base 12v on the grid, not exactly sure how that works.

Anyhow, thanks again, looking forward to more exploration.

P.S. And now in my desoldering to replace the pins I've somehow managed to muck something up; Cathode1 only displays 9,0 and 9 in place of 1.  Maybe this board will have to be used for 4-digit clock?

Title: Re: Questions from a dim bulb
Post by: Emblazed on March 29, 2010, 08:04:07 AM
Have you tried adjusting your delay time between bulb changes. The code posted on the forums are for IN-17s its possible that the bulbs your using need more time to warm up. Thus if you delay is to short you will not give the bulbs time to fully warm up before you switch to the next.

Just a thought.


Title: Re: Questions from a dim bulb
Post by: justfred on March 29, 2010, 09:05:26 AM
Yes, though I may not have waited long enough - after a few minutes, that bulb seems to "warm up" and light.

Here's the board with the new headers: